About Comparing Differences Between Drawings in AutoCAD

About Comparing Differences Between Drawings in AutoCAD

Compare the current drawing either to a different drawing or compare it to a previous version of your drawing as maintained on a supported cloud account.

As your design progresses, it becomes more difficult to remember what was changed from one revision to the next, especially when working in a remotely distributed team. This feature provides a way to perform a visual comparison between two drawings or two revisions of a drawing. Color and revision clouds highlight the differences in the current drawing as you work.

The ability to compare drawings is accessible from two different workflows:

DWG Compare

The COMPARE command provides a way of comparing the current drawing with a different drawing that you specify.

DWG History

The DWGHISTORY command displays a palette from which you can compare the current drawing with previous versions as maintained by a supported cloud storage provider. Supported cloud storage providers include Dropbox, Box, and Microsoft OneDrive.

The user interface and options in the comparison process are virtually identical, so the following example assumes that the DWG Compare feature is in operation. Comparing versions of a drawing saved to supported cloud storage providers are otherwise identical.

During the comparison process, the DWG Compare feature identifies objects that have been modified, added, or removed between the two drawings. For example, consider these two highly simplified drawings. Each drawing has differences that are not in the other drawing.

Comparison - Drawing 1 and Drawing 2

Let's say that drawing 1 is the previous version of a drawing, and drawing 2 is the current drawing.

When the COMPARE command is started, the DWG Compare toolbar displays at the top of the drawing area when you specify the comparison drawing, drawing 1 in this example.

DWG Compare toolbar

The result of the comparison is displayed in the current drawing, as shown below.

For better clarity, color-blind friendly colors were used in the illustrations that follow.
Result of the comparison in the current drawing
  1. Objects that are common between the drawings are displayed in gray by default.
  2. Objects that are in the comparison drawing but not in the current drawing are displayed in red by default.
  3. Objects that are in the current drawing but not in the comparison drawing are displayed in green by default.
  4. Differences are highlighted using revision clouds as change sets. The arrow buttons in the DWG Compare toolbar provide a way to zoom into each change set automatically.

You can specify different colors in the Settings panel of the DWG Compare toolbar. The Settings panel also provides additional display controls.

  1. When the comparison is active, changes to the current drawing are detected automatically.
  2. If the comparison drawing is also open, any changes you make in the comparison drawing do not display in a comparison until you save the changes.
  3. If you have a layer that is turned off or frozen in your current drawing, it does not become part of the comparison result.
  4. You can start the DWG Compare utility from the Application menu even when you do not have any open drawings. In the DWG Compare dialog, specify the base and reference drawing, and click Compare. The comparison result is shown in the base drawing.

Import Differences into the Current Drawing

From the DWG Compare toolbar, you can import differences from the compared drawing into the current drawing. Only those objects that are different in the comparison drawing can be imported into the current drawing. This command provides an efficient method to reconcile the current drawing with an earlier version.

Import Differences into the Current Drawing

Imported differences automatically turn gray because they are now present in both drawings.

Export the Comparison Result

You can export the results of a comparison into a new  snapshot drawing  for reference. The snapshot drawing maintains the visual appearance of the comparison and is named using a combination of the drawing names.

Export the Comparison Result
The snapshot drawing contains two blocks, one for each of the two compared drawings.

General Limitations

The limitations of the DWG Compare feature include the following:

  1. Operates in model space only. If a drawing selected for comparison was saved in a layout, DWG Compare automatically switches to the Model tab.
  2. Supports DWG files only.
  3. Does not support all object types. Exceptions include OLE objects, cameras, geographic data, GIS objects from Map 3D, non-DWG underlays, images, coordination models, and point clouds.
  4. Does not support using a comparison result to compare against a third drawing.
  5. Cannot detect ByBlock or ByLayer property changes within nested blocks.
  6. Comparison graphics are displayed only in the 2D Wireframe visual style. (AutoCAD only)
  7. Revision clouds cannot enclose changes in a 3D isometric view.
Powered by  AutoCAD ®
    • Related Articles

    • DWG Compare Limitations

      Drawing comparison does not support all object types in AutoCAD and AutoCAD specialized toolsets. Limitations for AutoCAD Object Types The DWG Compare feature does not support all object types in AutoCAD. The exceptions include OLE objects, cameras, ...
    • To Work with Comparing XREFs in AutoCAD

      Use various commands and display options in the Xref Compare toolbar to review the differences between the attached xref and the referenced drawing file. Compare the Xref Changes Click View tab > Palettes panel > External References Palette.   Find ...
    • Drawing Tools

      Drawing Tools To access the Drawing Tools, click on the Draw tab, and then select the Drawing Tools tab. The Drawing Tools interface has three tabs on the right side: Common Commands, Common Text, Common Blocks.   Common Commands Tab The Common ...
    • AutoCAD Keyboard Commands

      Learning how to use AutoCAD keyboard commands can help you work faster and improve your efficiency. This article lists the abbreviated commands that can be used in AutoCAD (Toolbox). Toggle General Features Ctrl+G Toggle Grid Ctrl+E Cycle isometric ...
    • About 2D Isometric Drawing

      Simulate an isometric view of a 3D object by aligning objects along three major axes.  A 2D isometric drawing is a flat representation of a 3D isometric projection. This method of drawing provides a fast way to create an isometric view of a simple ...
    • Recent Articles

    • The Range Hood - Add-on

      About the Library Add-on This is a “Master” Range Hood product capable of being used as is or saved back to the library numerous times in unlimited number of different combinations.  This Library Add-on is compatible with the Foundation Library. This ...
    • Toolbox Release Notes | Build 22.1.0406.641

      The following Release Notes apply to Toolbox Build 22.1.0406.641 Database Management Resolutions: Resolved an issue that caused template level projects to be deleted when deleting a seemingly “empty” category (this was caused by a mix-up in the ...
    • Microvellum Foundation Library Release Notes | Build 22.0407

      The following release notes apply to Microvellum Foundation Library, Build 22.0407 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...
    • Toolbox Release Notes | Build 22.1.0325.641

      The following Release Notes apply to Toolbox Build 22.1.0325.641 Toolfile Resolutions: Resolved an issue in certain post names where the pecking number was not working. Resolved an issue in certain post names where some face 6 machining was falling ...
    • Toolbox Release Notes | Build 22.1.0317.641

      The following Release Notes apply to Toolbox Build 22.1.0317.641 Database Resolutions: Resolved an issue where the user experience took longer than necessary to start.   Materials Resolutions: Resolved an issue where with formulated materials the ...