Adding a Custom Drawing Template to Toolbox

Adding a Custom Drawing Template to Toolbox

  1. Find the location of your existing drawing template that you want to use in Toolbox. 
    1. If you are using AutoCAD Standard, enter "Options" at the command prompt. 
      1. Click the Files tab, expand Template Settings > Drawing Template File Location, and note the location on disc for use in a later step. 
      2. Figure 1
        Fig. 01

    2. If you are using Toolbox, enter "Options" at the command prompt.
      1. Click the Files tab, expand Template Settings > Drawing Template File Location, and note the location on disc for use in a later step. The path for finding the location is the same, but the location will be different. 
      2. Figure 2
        Fig. 02

  2. Find the location of your Toolbox drawing templates. 
    1. Open Toolbox with the configuration in which you need to add your company template. Click "Help > Browse to Factory Data."
    2. Figure 3
      Fig. 03

    3. This opens a File Explorer window to the folder structure of your current configuration. In this case, the "Imperial Component Cabinet Library (049.0)."
    4. Figure 4
      Fig. 04

  3. Leave the existing File Explorer window, and open a new File Explorer window to the location noted in Step 1. 
  4. Figure 5
    Fig. 05

  5. In this tutorial, we have already modified the default template named "acad.dwt" to be our company drawing template. We want to use this template in Toolbox. Copy this file from the AutoCAD drawing template location to the Toolbox drawing template location. 
    1. In the File Explorer window, navigate to the AutoCAD drawing template location, right-click the file acad.dwt and select Copy. 
    2. In the File Explorer window, navigate to the Microvellum Toolbox drawing template location, right-click and select Paste. 
    3. Figure 6
      Fig. 06

  6. Start a new room in Toolbox and drop down the list box in the Template section of the Open Drawing box. Your company drawing template should be displayed in the list found there. Select your new template. 
  7. Figure 7
    Fig. 07

Attached to this article are the default Microvellum drawing templates in Imperial and Metric as of library build 049.0. 

    • Related Articles

    • Custom Hatches for Section Drawings

      Toolbox provides users the ability to assign a hatch pattern to materials for 2D section drawings.  To improve the flexibility of this feature, we have added the ability to attach a hatch pattern of your choice to each material.  This hatch pattern ...
    • Understanding Drawing Tabs

      Located at the bottom of the drawing area are tabs that allow you to switch between the Model tab and other layout tabs. While working in the drawing environment, you will need to have the Model tab selected. Selecting any other tab will bring you to ...
    • Working with the Rendering Templates in Toolbox

      The video below covers working with rendering templates. For help with adding a rendering template, see  Adding a Custom Drawing Template to Toolbox . The rendering templates used in this video are attached to this article below.
    • How to Configure Your AutoCAD Drawing Templates in Toolbox

      The video below demonstrates the process of configuring AutoCAD drawing templates and customizing the title block in Toolbox.
    • Drawing Tools

      Drawing Tools To access the Drawing Tools, click on the Draw tab, and then select the Drawing Tools tab. The Drawing Tools interface has three tabs on the right side: Common Commands, Common Text, Common Blocks.   Common Commands Tab The Common ...
    • Recent Articles

    • Microvellum Foundation Library Release Notes | Build 22.0729

      The following release notes apply to Microvellum Foundation Library, Build 22.0729 Note: This build (22.0729) contains the necessary requirements to support the new Microvellum "Library Update Utility". If your library version is older than 22.0729, ...
    • Toolbox Release Notes | Build 22.1.0720.641

      The following Release Notes apply to Toolbox Build 22.1.0720.641 Processing Stations Resolutions: Resolved an issue with the saw file output for Ardis processing stations when you have “None” set as the picture type. Resolved a refresh issue when ...
    • Toolbox Release Notes | Build 22.1.0712.641

      The following Release Notes apply to Toolbox Build 22.1.0712.641 Workbook Designer Resolutions: Resolved an issue with Part Properties updating the wrong 2D Plan Token workbook cells. Resolved an issue with saving formula materials through Workbook ...
    • Microvellum Foundation Library Release Notes | Build 22.0625

      The following release notes apply to Microvellum Foundation Library, Build 22.0625 Additions: Added Access Panel Subassembly (from legacy component library) Added the prompts "Extend Left Side To Floor" and "Extend Right Side To Floor" to all ...
    • Asking to Re-Activate Software on Start Up

      If your license is current, but you keep getting the Activate Software window when starting up Toolbox, this is the fix. Instead of entering your serial number and password every time, go to your MV Toolbox icon on your desktop and Right-click then ...