Understanding the Toolbox Palette

Getting to Know the Toolbox Palette

The Toolbox palette is comprised of three sections: the Toolbox, and two Tool Strips (located on each side of the Toolbox). The Toolbox can be a floating window, or it can be docked to the left or right side of the AutoCAD interface – auto-hide settings can be applied to help maximize the drawing area.


The Tool Strip that contains the large blue icons is the primary tool strip and is always displayed. Starting from the top, the Help icon will turn on the Microvellum Help allowing you to access the help documentation linked to the Toolbox buttons. The Draw icon will display common AutoCAD drawing commands (line, polyline, etc.). The Modify icon will display standard AutoCAD modify commands (erase, move, copy, etc.). The 3D View icon will display commands for navigating the AutoCAD drawing space. The View Style icon will display commands for changing the view style and commands for creating rendered images. The Miscellaneous icon will display various other AutoCAD commands and settings. Lastly, the Process icon (default), will display Microvellum commands for creating and editing work orders, and commands for working within a nest drawing.

The Tool Strip on the opposite side of the Toolbox is optional and can be customized to contain icons for commands you may use frequently. By default, the tool strip contains the following icons: Product Prompts, Part Properties, Edit Design Data, Draw Part in 2D, and Redraw Selected Product. To edit this list, click on the Edit Custom Toolbar icon (small gear cog) at the top of the tool strip.

The Toolbox section is the primary interface. It consists of four menus located across the top and the operations window (located below the menus), which contains five vertical tabs: Project, Draw, Modify, Solid Modeling, and Product Viewer.


The Company Setup menu allows you to access company-wide settings and information.


  1. Vendors – Allows you to add vendors for materials (must have the Purchasing module).
  2. Employees – Allows you to access the Employee Data interface, which allows you to add, set up, edit, and remove employees.
  3. Employees (Secure Information) – Allows you to set up secure information for employees, including setting up permissions to allow access to specific parts of the software.
  4. General Contacts – Allows you to enter companies, vendors, and other contacts.
  5. Import Data – Allows you to import default Microvellum settings such as employees, project activities, shifts, activity stations, and layers.
  6. Reports – Allows you to view and print factory reports (not work order reports). These reports are typically used for ERP software solutions.

The Toolbox Setup menu is the primary menu for accessing settings and information for the overall performance of the software.


  1. Walls Setup – Allows you to edit settings for how walls draw in 2D and 3D.
  2. Product Drawing Setup – Allows you to edit settings for 2D Drawings, Dynamic Product Images, and Face Frame Images.
  3. Library Specification Groups – Allows you to set up default (template) construction methods, materials, and other settings to be used in projects.
  4. Project Specification Groups – Allows you to edit the specification groups for a project.
  5. Options – Allows you to access and edit the Microvellum options. These settings will affect the way Microvellum performs and how it interacts with AutoCAD.
  6. Drawing Options – Allows you to access and edit the AutoCAD options. These settings will affect the way AutoCAD performs.
  7. Import from On-Screen Takeoff – Allows you to import a project estimate from On-Screen Takeoff.
  8. Import XLS File – Allows you to import an XLS file for creating manufacturing and reporting data.
  9. Import File – Allows you to import an XML file for creating manufacturing and reporting data.
  10. Design Reports – Allows you to access, edit, and create reports and labels.
  11. Show Tool Strip – Allows you to toggle the visibility of the secondary tool strip.
  12. Flip Tool Strip Menus – Flips the locations of the two tool strips.
  13. Library Designer – Allows you to open the Library Designer interface, which can be used to maintain your library data.

The Other menu only consists of two options: Select Entire Product and Migrate V67 Drawing.


Select Entire Product is a toggle option that allows you to either select a specific part within a product or select the entire product when any part of that product is selected (CTRL + H in AutoCAD also toggles the selection method and is quicker to use).

The Migrate V67 Drawing command will allow you to convert a Microvellum drawing from version 67 to work with the newer versions of the software. 

The Help menu contains other tools and information. 


  1. Browse to Factory Data – This will open Windows File Explorer to the directory where the stored data for the configuration has been mapped.
  2. View Event Log – Allows you to view a log of any messages (warnings or errors) that have occurred on a particular system.
  3. Support Portal – Opens your internet browser to the Microvellum Help Center website. From there, you can create a technical support ticket.
  4. Help on Microvellum – Opens the Help interface. The Help interface allows you to access and learn about the different portions of the software.
  5. About Microvellum – Opens another interface where you can view information about the software. You can also view the modules you have access to, access the Support Portal, and enter a permanent serial number. 

Project Tab

The Project tab allows you to access the commands for creating and editing projects. Certain icons become active as you open a project and a room. The Project tab will also display the Current Configuration, Current Project, Current Room, and Current Library.


  1. Projects – Allows you to create, edit, and organize projects.
  2. Project Properties – Allows you to edit the properties of a project and setup project specification groups.
  3. New Room – Allows you to create a new room within a project.
  4. Open Room – Allows you to open a room within a project.
  5. Copy Room – Allows you to copy a room within a project.
  6. Save Room – Allows you to save a room drawing (you can also use the AutoCAD command QSAVE).
  7. Update Title Block – Allows you to auto-fill portions of the Microvellum drawing title block (uses data from the Project Properties). Will also auto-fill portions of the Microvellum ‘Spec’ sheet.
  8. Room Properties – Allows you to edit the properties of a room within a project.
  9. Change Active Library – Allows you to switch between different libraries and their specification groups if more than one library is installed in a configuration.
  10. Product List (AKA Overdrive Pro) – Allows you to access a list of all the rooms and products within a project. The Product List is often used as a staging area for creating work orders.

Draw Tab

The Draw tab contains additional sub-tabs and allows you to draw Microvellum products and is also equipped with additional tools to help enhance shop drawings.


  1. Draw Room Components – Allows you to draw walls, moldings, floors, and ceilings, and add lighting for renderings.
  2. Draw Products – Allows you to draw library products. Products can be associated with walls or placed at any point within a drawing.
  3. Draw Appliances – Allows you to draw appliances such as refrigerators, ovens, etc.
  4. Draw Furniture – Allows you to draw furniture for enhancing drawings and creating renderings. Note: Furniture products are for drawing purposes only; these products do not contain manufacturing information.
  5. Draw Accessories – Allows you to draw accessories such as fixtures, small appliances, and kitchenware for enhancing drawings and creating renderings.
  6. Drawing Tools – Allows you to access AutoCAD commands quickly. It also allows you to quickly insert common text and common drawing blocks to enhance your drawings.
  7. 2D Drawings – Allows you to create 2D elevations and sections. It also allows you to draw face frame drawings and dynamic product images.

Modify Tab

The Modify tab allows you to access tools for making modifications to components and products.


  1. Modify Room Components – Allows you to access tools for modifying walls.
  2. Modify Products – Allows you to access tools for modifying products.
  3. Product Detailing – Allows you to access tools for creating on-the-fly, detailed drawings of products.
  4. Modify Subassemblies – Allows you to access tools for modifying subassemblies within products.
  5. Modify Parts – Allows you to access tools for making modifications to parts within products and/or subassemblies.

Solid Modeling Tab

For customers who have purchased modules within the Solid Modeling Tools, the Solid Modeling tab allows you to access tools for creating unique, custom products using 3D AutoCAD solids. These tools also allow you to create “smart” layers that are used in conjunction with the Extruded Product Builder and Custom Product Builder tools.

Product Viewer Tab

The Product Viewer tab allows you to view, in a table format, all the products that exist in the current room. The Product Viewer also contains tools for editing products, redrawing walls and products, and rebuilding subassemblies from the library (template).

    • Related Articles

    • Uninstalling Toolbox OEM

      These procedures explain the removal of Toolbox and supporting files while using Windows 10. Uninstalling Toolbox from “Apps and Features” Select the “Windows start icon”. Select “Settings”. Select “Apps”.                                              ...
    • Preparing Your Computer to Install Toolbox

      This tutorial demonstrates the steps recommend prior to installing Microvellum Toolbox and Toolbox AC (AutoCAD Companion). Prior to installing an update, we advise backing up your current data before initiating the process detailed below. Due to ...
    • Toolbox Standard 2023 Installation Best Practices

      The following article contains the recommended and necessary procedures for installing Microvellum’s Toolbox Standard AutoCAD 2023. In order to get the smoothest and highest quality experience, it is recommended to be running a graphics card with 4 ...
    • Getting to Know the AutoCAD Interface

      AutoCAD is the drawing platform for Microvellum. The AutoCAD interface can be completely customizable to suit your needs. The descriptions and images shown below are just an example of how AutoCAD can be configured. It is recommended to research best ...
    • How to Uninstall Toolbox AC (AutoCAD Companion)

      These procedures explain the removal of Toolbox 2020 AC (AutoCAD Companion) and supporting files while using Windows 10.   Uninstalling Toolbox 2020 AC from “Apps and Features” Select the “Windows start icon”. Select “Settings”. Select “Apps”. In ...
    • Recent Articles

    • Toolbox Release Notes | Build 24.1.0416.641

      The following release notes apply to Toolbox build 24.1.0416.641. Maestro Toolfile Fix There was an issue with Maestro SCM Toolfiles reportedly experienced by some users, wherein the labels output by autolabeling would be in incorrect positions, an ...
    • Toolbox Release Notes | Build 24.1.0409.641

      The following release notes apply to Toolbox build 24.1.0409.641 Saw Delimited Processing Station Figure 1: The Saw Delimited option in a custom processing station. New options have been added to saw processing stations to allow for control over data ...
    • Toolbox Release Notes | Build 24.1.0328.641

      The following release notes apply to Toolbox Build 24.1.0328.641 Fillet Token Fixes Issues were discovered in the use of fillet tokens on products that also had the IRIB setting enabled: Some users processed work orders with rounded parts, which ...
    • Microvellum Foundation Library Release Notes | Build 24.0322

      Additions Added the Master Angled Ends Cabinet. Added a Global prompt, "Hinge Plate Offset From Front" for easier control. Added “Double Division” option to Horizontal Designer Cabinets, 3 Door Cabinets, and other similar products. Added a new ...
    • Common Floating License Connectivity Issues

      This document lists common issues reported by users regarding the topic of Microvellum’s Floating License Activation (FLA) and the connectivity required for FLA to function. Firewall Blocking Activation of Floating License Some users have had an ...