Solid Modeling Tools - How to Modify the Construction Path to Change the Shape of your 3D Product in Plan View (Tutorial 2: Part 2)

Solid Modeling Tools - How to Modify the Construction Path to Change the Shape of your 3D Product in Plan View (Tutorial 2: Part 3)

This article continues from Solid Modeling Tools - How to Modify the Active 2D Section Drawing to Modify the 3D Product (Tutorial 2: Part 2) and provides information regarding working with construction paths. 


  1. Change the front overhang amount of the countertop. Click in the left viewport containing the section to activate it. Click on the upper countertop part to display its grips. Click on the midpoint grip on the left end of the part and move your cursor to the left. Without clicking, enter a value of 1.75 inches (44.5 if working in metric units). Repeat the process for the lower countertop part. 
  2. This will result in a countertop that is 12 inches wide (305 if working in metric units). 

  3. Round both top corners of the countertop. Enter "FILLETRAD" at the command prompt and enter 0.5 inches as the default. Enter "FILLET" and pick on the polyline near the corner to fillet, in this case, either left or right top corners of the countertop. Then pick near the corner on the adjacent side of the polyline that is the other leg of the corner. Repeat this for the other corner of the countertop. 
  4.  
    Fig. 01

  5. Add a skin to the inside of the product. 
    1. Enter "REC" at the command prompt and enter values of @0.25, 30.4 (16.35, 762 if working in metric units). Pick the lower right corner of the stud as the insertion point. 
    2. Enter "ROTATE" and select the lower-left corner as the base point to rotate around. Enter -5.7 degrees. 
  6. Add to the product tree. 
    1. Click in the left viewport containing the section drawing and zoom out so you can see the entire section. 
    2. Since you're adding an extruded skin to the product, right-click on Extruded Parts in the SMT Palette, and click Add. 
    3. Window the entire section and press Enter or right-click to confirm the selection. You don't have to worry about duplicate entry of existing parts as the program filters out those already assigned to a smart layer. Notice that the inside skin is the part selected in the drawing. Assign a smart layer to it from the Extruded Entities section of the interface and click Apply. 
    4. Take note that the skin is drawn as part of the 3D product, and the part is added to the product tree. 
  7. Add a vertex to the construction path that changes the configuration of the product entirely, but with minimal intervention by you. 
    1. Click in the right side viewport containing the 3D product and change the Visual Style from X-Ray to 2D Wireframe. 
    2.  
      Fig. 02 

    3. In the tree view, turn OFF everything except the Construction Path. 
    4.  
      Fig. 03

    5. Click on the construction path to highlight the grips and hover over the grip at the right end of the polyline (positive X). The vertex menu will be displayed when you hover, select Add Vertex from that menu. 
    6. What is an AutoCAD vertex, and why do we need to understand its function when working with SMT? A vertex is defined in this context as the point where two lines meet to form an angle. When you add a vertex, you are adding a line segment to the polyline, and as a result of adding a line, you are adding the angle between the lines. The construction path of an L-shaped wall contains a single vertex. The construction path of a Z-shaped wall contains multiple vertices. 
    7. The program will display a dashed line to represent the direction you intend to add the vertex. Move it in the positive Y direction and enter 50 (1270 if working in metric units). 
    8. If you're not familiar with which direction is positive when using the SW isometric view of Microvellum, we have another left-hand rule for you. The first was to define which side of the construction path the product would draw (Tutorial #1 of this series). This second one helps you remember which direction is positive X, Y, and Z. Hold your left hand up in front of you and point your thumb straight up in the air. Point your index finger straight forward, and point your middle finger to the right, at 90° to both your thumb and index finger. Your thumb is positive Z, your index finger is positive Y, and your middle finger is positive X. You may also use the UCS icon in the lower-left corner of the viewport. By default, it displays the positive direction of each axis. 
       
       
      Fig. 04  
      Fig. 05 

    9. In the tree view, turn ON everything by checking the checkbox next to the product name and watch as the program draws the custom product with the new design. 
  8. Save the drawing. 
  9. In a complicated drawing, you may need to edit a single part. For example, you may want to replace the end stud of a custom wall that is made of one material with a finished end stud of a different material, which does not contain a circular cutout. We haven't shown you how to do that yet, but in short, it usually involves right-clicking the part in the tree view list, selecting Edit, and making the modifications there. The problem you may encounter is how to determine which part in the 3D drawing corresponds to which part in the tree view list. The program helps you make that determination. Expand the Vertical Parts category and click a stud in the list under the category name. The corresponding part highlights in the 3D product. Click through the parts in the tree view until you find the part you want to edit. 
  10. Another tool that will help you to avoid confusion when working with complicated products is the ability to control the visibility of individual parts, complete categories of parts, or the entire product. For example, in step #17 above, we turned off the visibility of everything but the construction path so we could easily add a vertex. Without that ability, it can be challenging to select the appropriate entity. 
  11. Finally, we would like you to be aware that the commands for editing extruded entities and vertical entities are available both in the Tree View and in the Extruded Tools tabs. 
    1. As an example, suppose you want to modify a property of all the 3D parts drawn from the same 2D stud profile. Since they are all taken from one section profile, they will all be on the same smart layer. Notice below that on the Tree View tab, there is the part type name (Vertical Parts), the smart layer name (Stud-075), and the part names that are numbered (Stud-075 Section 1, etc.). The smart layer name is highlighted. 
    2.  
      Fig. 06 

      Right-click on the smart layer name as shown above and select Edit. This displays the properties that apply to all the parts drawn from that section profile on that smart layer. 

       
      Fig. 07 

      The identical properties are available by clicking the Extruded Tools tab, and the Vertical Entities > Edit Vertical Entities button. Select a 3D stud assigned to the same smart layer and notice that the properties displayed are the same. 

       
      Fig. 08 

    3. Another example would be to edit the parts assigned to that same smart layer. Click the Tree View tab, expand the part type name (Vertical Parts), expand the smart layer name (Stud-075), and right-click on one of the parts underneath the smart layer name. Click on Edit to view the part properties of that stud. 
    4.  
      Fig. 09 

      The part properties are split up between several different buttons. For example, there is a Rotate Vertical Entity button, and a button for Select An Alternate Profile. 

       
      Fig. 10 

       
      Fig. 11

The next subject in this tutorial series will show you how to engineer the construction details of your custom product to achieve the desired results. 



Click here  to view "Tutorial 3: Solid Modeling Tools (Engineering-Joints-WallArcs, Dados)." 



    • Recent Articles

    • The Range Hood - Add-on

      About the Library Add-on This is a “Master” Range Hood product capable of being used as is or saved back to the library numerous times in unlimited number of different combinations.  This Library Add-on is compatible with the Foundation Library. This ...
    • Toolbox Release Notes | Build 22.1.0406.641

      The following Release Notes apply to Toolbox Build 22.1.0406.641 Database Management Resolutions: Resolved an issue that caused template level projects to be deleted when deleting a seemingly “empty” category (this was caused by a mix-up in the ...
    • Microvellum Foundation Library Release Notes | Build 22.0407

      The following release notes apply to Microvellum Foundation Library, Build 22.0407 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...
    • Toolbox Release Notes | Build 22.1.0325.641

      The following Release Notes apply to Toolbox Build 22.1.0325.641 Toolfile Resolutions: Resolved an issue in certain post names where the pecking number was not working. Resolved an issue in certain post names where some face 6 machining was falling ...
    • Toolbox Release Notes | Build 22.1.0317.641

      The following Release Notes apply to Toolbox Build 22.1.0317.641 Database Resolutions: Resolved an issue where the user experience took longer than necessary to start.   Materials Resolutions: Resolved an issue where with formulated materials the ...