To Work with Splines

To Work with Splines

A spline is a smooth curve that passes through or near a set of points that influence the shape of the curve. 

Draw a Spline

  1. Click Home tab > Draw panel > Spline. 
  2. (Optional) Enter (Method). Then enter either (Fit Points) or cv (Control Vertices). 
  3. Specify the first point of the spline. 
  4. Specify the next point of the spline. Continue specifying points as needed. 
  5. Press Enter to end, or enter (Close) to close the spline. 

Draw a Spline Tangent to and Connecting Two Lines or Curves

  1. Click Modify tab > Blend Curves. 
  2. (Optional) Enter con (Continuity) and enter a tangency option. 
  3. Select a line or curve near an endpoint. 
  4. Select another line or curve near an endpoint. 

Convert a Spline-Fit Polyline to a Spline

  1. Click Home tab > Draw panel > Spline. 
  2. Enter (Object). 
  3. Select a spline-fit polyline and press Enter. 
  4. The selected Object changes from a polyline to a spline. 
Powered by  AutoCAD ®
    • Related Articles

    • How to Join Polylines, Splines, Lines, and Arcs Into a Single Polyline

      Click Home tab/Modify panel/Edit Polyline.   (Find) Select a polyline, spline, line, or arc to edit. If you selected a spline, line, or arc, press Enter to convert the selected object into a polyline. Enter "J" (Join). Select one or more polylines, ...
    • Drawing Polylines

      Draw polylines with straight or curved segments. Define the width for the polyline segments and taper the width across the segment. Draw polygons specifying the number of sides and size. Draw a Polyline with Straight Segments Click Home tabDraw ...
    • AutoCAD Keyboard Commands

      Learning how to use AutoCAD keyboard commands can help you work faster and improve your efficiency. This article lists the abbreviated commands that can be used in AutoCAD (Toolbox). Toggle General Features Ctrl+G Toggle Grid Ctrl+E Cycle isometric ...
    • Modifying Polylines

      Stretch a Segment You can select a grip to make changes directly. Select the polyline to display its grips. Select a grip and drag it to the new location. Menu Options for Modifying Polylines Several options become available when you select a ...
    • To Work with Comparing XREFs in AutoCAD

      Use various commands and display options in the Xref Compare toolbar to review the differences between the attached xref and the referenced drawing file. Compare the Xref Changes Click View tab > Palettes panel > External References Palette.   Find ...
    • Recent Articles

    • Microvellum Foundation Library Release Notes | Build 22.0520

      The following release notes apply to Microvellum Foundation Library, Build 22.0520 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...
    • The Range Hood - Add-on

      About the Library Add-on This is a “Master” Range Hood product capable of being used as is or saved back to the library numerous times in unlimited number of different combinations.  This Library Add-on is compatible with the Foundation Library. This ...
    • Toolbox Release Notes | Build 22.1.0406.641

      The following Release Notes apply to Toolbox Build 22.1.0406.641 Database Management Resolutions: Resolved an issue that caused template level projects to be deleted when deleting a seemingly “empty” category (this was caused by a mix-up in the ...
    • Microvellum Foundation Library Release Notes | Build 22.0407

      The following release notes apply to Microvellum Foundation Library, Build 22.0407 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...
    • Toolbox Release Notes | Build 22.1.0325.641

      The following Release Notes apply to Toolbox Build 22.1.0325.641 Toolfile Resolutions: Resolved an issue in certain post names where the pecking number was not working. Resolved an issue in certain post names where some face 6 machining was falling ...