Tool File Access and Machining Properties (Reference)

Tool File Access & Machining Properties (Reference)

The purpose of this article is to provide a reference for the updated Tool File and Machining tabs. These interface changes can be found in Toolbox builds 15.6.2201 and greater. 

Getting There


Fig. 01 - Access for Tool Files and Machining Properties

Tool File Interface


Fig. 02 - Access for Tool Files

The Tool File menu provides the user with a variety of commands.


Fig. 03 – Tool File Command Buttons  

  1. Set as Primary -  Allows user to set a primary Tool File from a list of Tool Files. 
  2. Edit in User Interface -  Opens the Tool File user interface. 
  3. Edit in Spreadsheet -  Opens the selected Tool File in the Tool File Spreadsheet. 
  4. Rename -  Enables renaming of the selected Tool File. 
  5. Copy -  Copies selected Tool File. 
  6. Delete -  Deletes selected Tool Files. 
  7. Import -  Imports Tool Files. 
  8. Export -  Exports Tool Files. 
  9. Export as XLSX -  Exports selected Tool Files as an XLSX. 

Each Tool File row can be individually selected by single left-clicking. Double left-clicking a row will open a new window to edit the Tool File in the user interface. The user can select multiple rows while holding ctrl + left click to select only the rows desired. Additionally, the user can hold shift while selecting two rows, and all the rows in-between will be selected.

Machining Interface


Fig. 04 - Access for Machining Properties

The Machining tab and some of its contents are now separate from the Toolfile options and include all the same functionality as previous versions.

A standard search bar was added to all of the option tabs.


Fig. 05 – Search Bar in Options Tabs

The search bar will enable the user to locate the desired command or property with ease.


Fig. 06 - Search Bar Finding the Desired Command or Property
    • Related Articles

    • Overview: Integrated Post Processor Tool Files (IPP)

      This article presents an overview of the design and functionality of the “Integrated Post Processor” type tool files. We will refer to them as IPP tool files hereafter in this article. One of the strengths of Microvellum has been in its ability to ...
    • Understanding the Tool File Interface

      This article provides an overview of the options and settings available on the Tool Files tab of the Configuration Editor (Options) Interface.  For a complete list of available tabs and options visit Overview: Configuration Editor (Options) ...
    • Importing a Tool File

      This article explains the steps to import a new toolfile. Hover over "Toolbox Setup" and select "Options." Select the "Toolfiles" tab and select the "Import" button. Select the desired toolfile to import.  After successful import, observe the ...
    • 2D Machining Tools

      The 2D Machining Tools tab contains several other sub-tabs: Part Information – This includes information on the part and also allows you to place pods and make single part g-code for point-to-point machines. Vertical Drilling Tools – Contains a list ...
    • Tutorial: 2D Machining Tools

      General procedure overview:  Create a new nest sheet.  Add parts to the sheet.  Add machining to the parts.  Modify the nest sheet layout as needed.  Generate G-Code for the nest sheet. Click the button on the MV palette "Nest Editing and 2D ...
    • Recent Articles

    • Microvellum Foundation Library Release Notes | Build 22.0729

      The following release notes apply to Microvellum Foundation Library, Build 22.0729 Note: This build (22.0729) contains the necessary requirements to support the new Microvellum "Library Update Utility". If your library version is older than 22.0729, ...
    • Toolbox Release Notes | Build 22.1.0720.641

      The following Release Notes apply to Toolbox Build 22.1.0720.641 Processing Stations Resolutions: Resolved an issue with the saw file output for Ardis processing stations when you have “None” set as the picture type. Resolved a refresh issue when ...
    • Toolbox Release Notes | Build 22.1.0712.641

      The following Release Notes apply to Toolbox Build 22.1.0712.641 Workbook Designer Resolutions: Resolved an issue with Part Properties updating the wrong 2D Plan Token workbook cells. Resolved an issue with saving formula materials through Workbook ...
    • Microvellum Foundation Library Release Notes | Build 22.0625

      The following release notes apply to Microvellum Foundation Library, Build 22.0625 Additions: Added Access Panel Subassembly (from legacy component library) Added the prompts "Extend Left Side To Floor" and "Extend Right Side To Floor" to all ...
    • Asking to Re-Activate Software on Start Up

      If your license is current, but you keep getting the Activate Software window when starting up Toolbox, this is the fix. Instead of entering your serial number and password every time, go to your MV Toolbox icon on your desktop and Right-click then ...