Using the Group Products Command in Microvellum

Using the Group Products Command in Microvellum

Group Products Command

Using the "Group Products" command allows you to save multiple products together that you can then add to other projects. The command will remember how the products were positioned and draw them back the same way. Any prompt changes or modifications made to the products will also be saved with the product group.

After selecting this command, select the products in the drawing that you want to save together. In addition to products, you can also select walls drawn in the drawing to save with the product group. You will then need to select a base point for this product group. This point will be used as the insertion point when you are drawing this product group back into a drawing. The product group's window will be displayed where you can give this product group a name.

To draw a product group into the drawing, select the "Product Groups" tab while in the "Draw Products" section. Select the product group you want to draw and right-click. The only placement method for drawing a product group is to pick a point in the drawing. Before the product is drawn, you must enter a rotation angle. This will rotate the entire product group to the angle you specify. The right-click context menu will also allow you to delete the product group that is currently selected.

Create a Product Group

  1. Draw the products to be grouped.

  2. Fig. 01 – Products, and Wall, to be Grouped

  3. Select “Modify > Modify Products > Group Products.” 
  4. Select all of the products to be included in the group.
  5. Select the base point of the new product group.
  6. Give the product group an identifiable name.

  7. Fig. 02 – Enter New Product Group Name

Draw a Product Group

  1. Navigate to "Draw > Draw Products" and select the "Product Groups" tab.  

  2. Fig. 03 – Product Groups Location in Draw

  3. Right-click the product group to be drawn and select "Add Product Group to Project."
  4. Place the product at the desired location in the drawing window.
  5. Enter the desired rotation value.

Other Options

Right-click the product group of your choice, from within the Draw tab, to view additional options.


Fig. 04 – Other Options for Product Groups
  1. Delete Selected Product Group – Select this to delete a product group permanently.
  2. Rename Product Group – Select this option to rename a product group.
  3. Add Image to Product Group – Select this option to add an image to a product group. The image will be displayed beneath the list of product groups, within the Draw tab, while the correct product group is selected.  

  4. Fig. 05 – Product Groups tab with Image Added
    • Related Articles

    • Using the Replace Products Command in Microvellum

      Replace Products Using the Replace Product command allows you to replace a product currently in the drawing with another product from the product library. After selecting the product in the drawing you would like to replace, a window will be ...
    • Tutorial: Using the Group Parts Command

      This article gives an example of how to use the Group Parts command for creating a one-off product in the AutoCAD design environment. After creating the base product, you may add formulas to expand the flexibility and functionality of your product. ...
    • Working in the Modify Products Tab

      Modify Products Tab Part Properties See the Part Properties section within the Knowledge Network. Edit Multiple Product Prompts See How to Modify Multiple Products using Edit Multiple Product Prompts. Replace Products See Using the Replace Products ...
    • Tutorial: Create a New Spec Group

      This brief article provides the steps necessary to create a new spec group within the Project Specification Groups interface.  With Toolbox open, click "Toolbox Setup > Project Specification Groups." Select a spec group.  Click the "Copy Spec Group" ...
    • Creating 2D Drawings of Custom Products

       2D Drawings of Custom Products Products made using the Solid Model Tools may contain more drawing instructions than necessary and can create a 2D drawing that can look busy or confusing. Using other AutoCAD commands can make this process easier. ...
    • Recent Articles

    • Asking to Re-Activate Software on Start Up

      If your license is current, but you keep getting the Activate Software window when starting up Toolbox, this is the fix. Instead of entering your serial number and password every time, go to your MV Toolbox icon on your desktop and Right-click then ...
    • Toolbox Release Notes | Build 22.1.0620.641

      The following Release Notes apply to Toolbox Build 22.1.0620.641 Reports & Labels Resolutions: Resolved an issue with the auto-label rotation when you create new g-code from a batch drawing. Resolved an issue with certain saws that prevented the ...
    • Toolbox Release Notes | Build 22.1.0607.641

      The following Release Notes apply to Toolbox Build 22.1.0607.641 Report Groups Resolutions: Removed and extra "BMP" choice for the HTML format.   Resolved an issue that prevented changing the scaling in HTML output. Resolved an issue that caused ...
    • Toolbox Release Notes | Build 22.1.0525.641

      The following Release Notes apply to Toolbox Build 22.1.0525.641 Database Management Resolutions: Resolved an issue that caused products and subassemblies to need to be imported twice in order to see them in Toolbox.  Resolved an issue with ...
    • Microvellum Foundation Library Release Notes | Build 22.0520

      The following release notes apply to Microvellum Foundation Library, Build 22.0520 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...