2D Machining Tools

Overview: 2D Machining Tools

Back by popular demand is the ability to create one-off parts, nested panels and parts, and G-Code from all of them.

Smaller shops and others that know exactly the dimensions of the single parts they want to produce need this feature. It is a quick and easy way to produce single parts without using the full capabilities of Microvellum and its libraries.

Two interfaces within Microvellum support placement of custom drilling and routing machine operations. One accesses the 2D Part Editing Tools from the command "Modify > Draw Part in 2D," which requires you to select a 3D part to modify. The other is the "2D Machining Tools" interface that supports the direct creation of parts and the addition of machining to those parts, as discussed in this article.

The interface for "2D Machining Tools" is used for a different purpose than the 2D Part Editing Tools. Use the 2D Part Editing Tools to add machining to, or modify machining on specific existing parts. Use the 2D Machining Tools to create new nested sheets and add parts to them, or new single parts and add machining to them.

Current Processing Station

The top-level component on the 2D Machining Tools interface is a dropdown list for the selection of the processing station to use for your nests and parts. These are the same processing stations that are displayed within the Processing Center. Edit the Processing Station from this interface by selecting your station and clicking on the ellipsis button immediately to the right of the dropdown list, or leave it set to the default value that is displayed.


Current Work Order

The second component on the 2D Machining Tools interface is a dropdown list for the selection of the Current Work Order. If a work order has been opened in the Processing Center already in this Toolbox session, the Current Work Order box will contain that work order name, as shown above. If the opposite is true and a work order has not been opened in this session, the Current Work Order box will be empty, as shown below.


Below that, the interface tabs are as follows:

Nest Tools tab

This tab contains tools that you use to create nest sheets of a given size and material and add it to a work order. 

There are also part placement tools for manipulating the parts on the nest sheet. Here are the Microvellum nest editing tools. The commands available here are "Move Part," "Copy Part," "Erase Part," "Rotate Part in Nest," "Change Parts Border Setmill Location" (reading left to right, top to bottom).


You may also use the AutoCAD commands for Move, Copy, Rotate, or Erase.

If you use the AutoCAD commands, be sure to include ALL the information associated with that part, including the machining, setmill data, offset indicator, tabs, etc. when selecting the components to include. Don't leave anything associated with that part behind.

And finally, there are tools for miscellaneous operations in the "Machining" area. These include "Create New Machining Instructions and G-Code from Drawing," "Update G-Code Files from Drawing," "Show Machining Properties," "Make Center Line Nest," "Add Tab to Nest," "Assign Priorities to Routes," and "Assign Priorities to Borders."


Part Tools tab

This tab contains tools that you use to create single parts to add to a nest or to add as single stand-alone parts for a point-to-point machine. 

There are tutorials outlining the specific steps necessary to add parts elsewhere in the Knowledge Base, but here are the general steps.

Fill out the Name, Length, Width, Border Tool in the Part Information section.

Click the Select Existing button to select AutoCAD closed polyline geometry that has already been drawn.

Click the Draw button to select a location in the drawing to locate the part. This can be either inside nested sheet borders or outside. If outside, a label is drawn containing the part name, dimensions, and material.


Vertical Drilling Tools tab

Use this tab to add vertical drill machining to either nest parts or single parts destined for the point-to-point machine. The tools available under this tab reflect those configured in the toolfile.


Horizontal Drilling Tools tab

Use this tab to add horizontal drill machining to either nest parts or single parts destined for the point-to-point machine. The tools available under this tab reflect those configured in the toolfile.


Routing Tools tab

Use this tab to add route machining to either nest parts or single parts destined for the point-to-point machine. The tools available under this tab reflect those configured in the toolfile.


Route Editing Tools tab

Use this tab to customize existing route machining. These include: "Reverse Polyline Direction," "Change Setmill (used to modify the tool entry point in part's non-border machining operations)," "Step-Through Polyline," "Hatch Polyline (use for creating a pocket from a polyline)," "Show Center Line Path," "Settings," "Add Lead-In to Polyline," "Add Lead-Out to Polyline." If you need to modify the Z Value or Feed Speed of a polyline machining definition, use the "Select Polyline" button in the section Modify Polyline Properties and change the values in the appropriate text boxes.


Sawing Tools tab

Use this tab to add saw machining to either nest parts or single parts destined for the point-to-point machine. The tools available under this tab reflect those configured in the toolfile.


Enjoy using the 2D Machining Tools and let us know what you think.

    • Related Articles

    • 2D Machining Tools (Single Parts)

      As of Microvellum Toolbox 2020 | Build 15.6.228, there are two significant changes to the way the 2D Machining Tools operate. Updating Machine Token Values The program now updates existing machine tokens differently.  Previously, if you drew a part ...
    • 2D Machining Tools

      The 2D Machining Tools tab contains several other sub-tabs: Part Information – This includes information on the part and also allows you to place pods and make single part g-code for point-to-point machines. Vertical Drilling Tools – Contains a list ...
    • Tutorial: 2D Machining Tools

      General procedure overview:  Create a new nest sheet.  Add parts to the sheet.  Add machining to the parts.  Modify the nest sheet layout as needed.  Generate G-Code for the nest sheet. Click the button on the MV palette "Nest Editing and 2D ...
    • Overview: Integrated Post Processor Tool Files (IPP)

      This article presents an overview of the design and functionality of the “Integrated Post Processor” type tool files. We will refer to them as IPP tool files hereafter in this article. One of the strengths of Microvellum has been in its ability to ...
    • Understanding the Nest Editing and 2D Machining Tools Interface

      Understanding the Nest Editing and 2D Machining Tools Interface To access these tools, click on the Nest Editing and 2D Machining Tools icon in the Toolbox tool strip under the Process menu. The interface is the same as the 2D Machining Tools, except ...
    • Recent Articles

    • Asking to Re-Activate Software on Start Up

      If your license is current, but you keep getting the Activate Software window when starting up Toolbox, this is the fix. Instead of entering your serial number and password every time, go to your MV Toolbox icon on your desktop and Right-click then ...
    • Toolbox Release Notes | Build 22.1.0620.641

      The following Release Notes apply to Toolbox Build 22.1.0620.641 Reports & Labels Resolutions: Resolved an issue with the auto-label rotation when you create new g-code from a batch drawing. Resolved an issue with certain saws that prevented the ...
    • Toolbox Release Notes | Build 22.1.0607.641

      The following Release Notes apply to Toolbox Build 22.1.0607.641 Report Groups Resolutions: Removed and extra "BMP" choice for the HTML format.   Resolved an issue that prevented changing the scaling in HTML output. Resolved an issue that caused ...
    • Toolbox Release Notes | Build 22.1.0525.641

      The following Release Notes apply to Toolbox Build 22.1.0525.641 Database Management Resolutions: Resolved an issue that caused products and subassemblies to need to be imported twice in order to see them in Toolbox.  Resolved an issue with ...
    • Microvellum Foundation Library Release Notes | Build 22.0520

      The following release notes apply to Microvellum Foundation Library, Build 22.0520 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...