Solid Modeling Tools - How to Modify a Product by Adding a Wall Arc (Tutorial 4: Part 1)

Solid Modeling Tools - How to Modify a Product by Adding a Wall Arc (Tutorial 4: Part 1)

This is the fourth in a series of articles containing tutorials designed to acquaint you with the basic steps in using the Microvellum Solid Modeling Tools. You may also know these tools as SMT.

The steps contained in this tutorial start where tutorial #3 left off. Here are the subjects we will include in this tutorial:

  • How to modify a product by adding a wall arc.
  • How to apply dado joints to your product.
  • How to apply dowel joints to your product.

 At the end of this tutorial, we will give you a link to the next tutorial in the series.



How to Modify a Product by Adding a Wall Arc

Many of the designs you will engineer using SMT involve arcs of varying radii and chord lengths. This section of the tutorial shows you how to convert your custom product into one that contains an arced wall.

  1. Use the procedures you’ve already learned for the following steps.
    1. Open a new room.
    2. Set up your drawing with viewports if not already in the drawing.
    3. Draw a polyline construction path (70 inches [1778 mm] in the positive X-axis, and 50 inches [1270 mm] in the positive Y-axis).
    4. Draw a section of your product.
    5. Create a new product in the Tree View tab.
    6. Add extruded parts.

    Your drawing should now contain a 3D product.

  2. Modify the first leg of the construction path to be longer, and redraw the product in 3D.
    1. Hide everything but the construction path by checking OFF the checkbox next to your product name in the tree view tab. Then check ON the checkbox for the construction path. This will display only the path so you can easily modify it.
    2. Click on the path to display the grips.
    3. Hover over the mid grip on the second leg of the polyline and click Stretch.

    4. Fig. 1

    5. Move the grip in the direction of positive X and enter 30 (762 if working in metric units)—press Enter. The length of the first leg of the polyline should now be 100 (2540 if working in metric units).

    6. Fig. 2

    7. Redraw the 3D product by checking OFF the checkbox next to your product name in the tree view tab. Then check ON that same checkbox.
  3. It is also possible to modify the construction path without hiding the extruded and vertical parts.
    1. Set the 3D viewport visual style to “X-Ray.”
    2. Check OFF the checkbox for the Construction Path, and then check it back ON. You will see that the construction is visible through the 3D product.
    3. Hover over the mid grip on the first leg of the polyline and click Convert to Arc.
    4. Move it in the direction of negative Y and enter 25 (635 if working in metric units). Press Enter. When it re-draws, it should appear similar to the figure below. Notice the joints in the extruded entities (countertop, and plates if you look closely).

    5. Fig. 3

  4. Remove all the existing joints and add joints at the arc transition and arc peak.
    1. Click: “Extruded Tools > Extruded Entities > Remove Extruded Entity Joint.”

    2. Fig. 4

    3. Select the extruded parts from which to remove the joints. Make this selection either by selecting them individually by using a crossing window selection (drag right to left) or by using a window selection (left to right), as shown below. This will remove the first joint in each extruded part encountered for each part.

    4. Fig. 5


      Fig. 6

    5. To remove the remaining joints, we have two options.
      1. Remove all the remaining joints by repeating the command above with a crossing window or a regular window selection.
      2. Use the command above the select the part individually.

      The extruded parts should now contain no joints, as shown below.


      Fig. 7

  5. Now that all the existing extruded joints have been removed let’s add a joint at the first location of our choice instead of the ones inserted by the software. In this case, the first joint we want to insert is at the intersection of the arced countertop segment and the straight segment.

  6. Fig. 8

    1. Click: “Extruded Tools > Extruded Entities > Insert Extruded Entity Joint.”

    2. Fig. 9

    3. Select the extruded parts for which to add the joints. Make this selection either by selecting them individually, by using a crossing window selection (drag right to left).

    4. Fig. 10

    5. In this example, select the outside corner of the countertop part when the program asks you to select a point on the polyline path.

    6. Fig. 11

    7. Exit the command by pressing Enter or right-clicking. Notice the joints that were added to the extruded parts.

    8. Fig. 12

  7. We also want to insert a joint at the apex of the arc segment of the wall. Repeat the basic steps from the previous step.
    1. View the 3D model from the front and slightly above.
    2. Click: “Extruded Tools > Extruded Entities > Insert Extruded Entity Joint.”
    3. Make a selection crossing across all the extruded entities.
    4. Select the midpoint of the outer circumference of the arc when asked to select a point.
    5. Exit the command by pressing Enter or right-clicking.
  8. Save the drawing. 
    • Related Articles

    • Solid Model Analyzer - SMA (Overview)

      Description Solid Model Analyzer is a powerful tool included in certain product levels of Microvellum. The design and manufacturing industry is steadily moving closer to the adoption of 3D design for its verification and visualization abilities. The ...
    • Solid Modeling Tools - How to Apply Dado Joints to Your Product (Tutorial 4: Part 2)

      This article continues from Solid Modeling Tools - How to Modify a Product by Adding a Wall Arc  and provides information for applying dado joints to your product.  This step will show you how to configure your product for dado joints at the stud ...
    • Solid Modeling Tools - How to Apply Dowel Joints to Your Product (Tutorial 4: Part 3)

      This article continues from Solid Modeling Tools - How to Apply Dado Joints to Your Product  and provides information for applying dowel joints to your product.  This step will show you how to configure your product for dowel joints at the stud ...
    • Solid Model Analyzer - SMA (Reference)

      This article is a reference article explaining how to work with various types of products in the Solid Model Analyzer, also known as SMA. It also explains the commands and properties that apply to SMA. See Using Solid Model Analyzer - SMA ...
    • Solid Model Analyzer - SMA (Tutorial)

      Description This document gives you a step-by-step tutorial on how to use the Solid Model Analyzer (SMA) to create a Microvellum product from a solid model. Before using this tutorial, you need to have a solid model in an AutoCAD DWG file. You may ...
    • Recent Articles

    • The Range Hood - Add-on

      About the Library Add-on This is a “Master” Range Hood product capable of being used as is or saved back to the library numerous times in unlimited number of different combinations.  This Library Add-on is compatible with the Foundation Library. This ...
    • Toolbox Release Notes | Build 22.1.0406.641

      The following Release Notes apply to Toolbox Build 22.1.0406.641 Database Management Resolutions: Resolved an issue that caused template level projects to be deleted when deleting a seemingly “empty” category (this was caused by a mix-up in the ...
    • Microvellum Foundation Library Release Notes | Build 22.0407

      The following release notes apply to Microvellum Foundation Library, Build 22.0407 Please make sure you are selecting the correct specification group when drawing products. There may be specification groups for both metric and imperial. Additions: ...
    • Toolbox Release Notes | Build 22.1.0325.641

      The following Release Notes apply to Toolbox Build 22.1.0325.641 Toolfile Resolutions: Resolved an issue in certain post names where the pecking number was not working. Resolved an issue in certain post names where some face 6 machining was falling ...
    • Toolbox Release Notes | Build 22.1.0317.641

      The following Release Notes apply to Toolbox Build 22.1.0317.641 Database Resolutions: Resolved an issue where the user experience took longer than necessary to start.   Materials Resolutions: Resolved an issue where with formulated materials the ...